Parcourir la source

package/qt5/qt5remoteobjects: new package

Qt 5.12 added a library for IPC, so let's have a package for it. The
dependency on qtdeclarative is optional.

Signed-off-by: Sven Fischer <sven@leiderfischer.de>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Sven Fischer il y a 4 ans
Parent
commit
e7ebc7cd09

+ 3 - 0
DEVELOPERS

@@ -2538,6 +2538,9 @@ F:	configs/rock_pi_n10_defconfig
 F:	configs/rockpro64_defconfig
 F:	package/arm-gnu-a-toolchain/
 
+F:	Sven Fischer <sven@leiderfischer.de>
+N:	package/qt5/qt5remoteobjects/
+
 N:	Sven Haardiek <sven.haardiek@iotec-gmbh.de>
 F:	package/lcdproc/
 F:	package/python-influxdb/

+ 1 - 0
package/qt5/Config.in

@@ -50,6 +50,7 @@ source "package/qt5/qt5multimedia/Config.in"
 source "package/qt5/qt5quickcontrols/Config.in"
 source "package/qt5/qt5quickcontrols2/Config.in"
 source "package/qt5/qt5quicktimeline/Config.in"
+source "package/qt5/qt5remoteobjects/Config.in"
 source "package/qt5/qt5script/Config.in"
 source "package/qt5/qt5scxml/Config.in"
 source "package/qt5/qt5sensors/Config.in"

+ 15 - 0
package/qt5/qt5remoteobjects/Config.in

@@ -0,0 +1,15 @@
+config BR2_PACKAGE_QT5REMOTEOBJECTS
+	bool "qt5remoteobjects"
+	select BR2_PACKAGE_QT5BASE
+	select BR2_PACKAGE_QT5BASE_NETWORK
+	help
+	  Qt is a cross-platform application and UI framework for
+	  developers using C++.
+
+	  Qt Remote Objects (QtRO) is an Inter-Process
+	  Communication (IPC) module developed for Qt. This
+	  module extends Qt's existing functionalities to enable
+	  information exchange between processes or computers,
+	  easily.
+
+	  https://doc.qt.io/qt-5/qtremoteobjects-index.html

+ 8 - 0
package/qt5/qt5remoteobjects/qt5remoteobjects.hash

@@ -0,0 +1,8 @@
+# Hash from: https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtremoteobjects-everywhere-src-5.15.1.tar.xz.sha256
+sha256 71b58fdac717645fa6f8b6ecb79b86841c540838877d100fabe2381175c4154e  qtremoteobjects-everywhere-src-5.15.1.tar.xz
+
+# Hashes for license files:
+sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 LICENSE.GPL2
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
+sha256 0dbe024961f6ab5c52689cbd036c977975d0d0f6a67ff97762d96cb819dd5652 LICENSE.GPL3-EXCEPT
+sha256 da7eabb7bafdf7d3ae5e9f223aa5bdc1eece45ac569dc21b3b037520b4464768 LICENSE.LGPL3

+ 19 - 0
package/qt5/qt5remoteobjects/qt5remoteobjects.mk

@@ -0,0 +1,19 @@
+################################################################################
+#
+# qt5remoteobjects
+#
+################################################################################
+
+QT5REMOTEOBJECTS_VERSION = $(QT5_VERSION)
+QT5REMOTEOBJECTS_SITE = $(QT5_SITE)
+QT5REMOTEOBJECTS_SOURCE = qtremoteobjects-$(QT5_SOURCE_TARBALL_PREFIX)-$(QT5REMOTEOBJECTS_VERSION).tar.xz
+QT5REMOTEOBJECTS_DEPENDENCIES = qt5base
+QT5REMOTEOBJECTS_INSTALL_STAGING = YES
+QT5REMOTEOBJECTS_LICENSE = GPL-2.0+ or LGPL-3.0, GPL-3.0 with exception (tools), GFDL-1.3 (docs)
+QT5REMOTEOBJECTS_LICENSE_FILES = LICENSE.GPL2 LICENSE.GPL3 LICENSE.GPL3-EXCEPT LICENSE.LGPL3 LICENSE.FDL
+
+ifeq ($(BR2_PACKAGE_QT5DECLARATIVE),y)
+QT5REMOTEOBJECTS_DEPENDENCIES += qt5declarative
+endif
+
+$(eval $(qmake-package))