Browse Source

package/libcodec2: disable unittest

Quoting
https://svn.code.sf.net/p/freetel/code/codec2-dev/CMakeLists.txt
"# Unittest should be on for dev builds and off for releases."

If unittest is enabled libcodec2 depends on speex and libsamplerate.
To avoid these dependencies we simply disable unittest.

Fixes
http://autobuild.buildroot.net/results/da2/da2b6402c8fabd85a9ee728e8dbf7b78c5aa801e/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Bernd Kuhls 6 years ago
parent
commit
e2385ce1f4
1 changed files with 1 additions and 0 deletions
  1. 1 0
      package/libcodec2/libcodec2.mk

+ 1 - 0
package/libcodec2/libcodec2.mk

@@ -11,6 +11,7 @@ LIBCODEC2_LICENSE = LGPL-2.1
 LIBCODEC2_LICENSE_FILES = COPYING
 LIBCODEC2_INSTALL_STAGING = YES
 LIBCODEC2_SUPPORTS_IN_SOURCE_BUILD = NO
+LIBCODEC2_CONF_OPTS = -DUNITTEST=OFF
 
 ifeq ($(BR2_PACKAGE_LIBCODEC2_EXAMPLES),y)
 LIBCODEC2_CONF_OPTS += -DINSTALL_EXAMPLES=ON