Browse Source

googlefontdirectory: new package

Note that the Google code project does not provide an archive containing
just the font files. This package uses the third party archive provided at

  http://joemaller.com/1856/download-google-fonts/

Further information is available at the following URL.

  http://code.google.com/p/googlefontdirectory/issues/detail?id=2

[Peter: drop version, fix install and simplify uninstall]
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Simon Dawson 11 years ago
parent
commit
dfaf64fe5a

+ 1 - 0
package/Config.in

@@ -519,6 +519,7 @@ endmenu
 menu "Miscellaneous"
 source "package/collectd/Config.in"
 source "package/empty/Config.in"
+source "package/googlefontdirectory/Config.in"
 source "package/mobile-broadband-provider-info/Config.in"
 source "package/shared-mime-info/Config.in"
 source "package/sound-theme-borealis/Config.in"

+ 13 - 0
package/googlefontdirectory/Config.in

@@ -0,0 +1,13 @@
+config BR2_PACKAGE_GOOGLEFONTDIRECTORY
+	bool "Google font directory"
+	help
+	  Google font directory
+
+	  http://code.google.com/p/googlefontdirectory/
+
+config BR2_PACKAGE_GOOGLEFONTDIRECTORY_FONTS
+	string "List of fonts to install"
+	default "droid"
+	depends on BR2_PACKAGE_GOOGLEFONTDIRECTORY
+	help
+	  Specify a space-separated list of fonts to install

+ 27 - 0
package/googlefontdirectory/googlefontdirectory.mk

@@ -0,0 +1,27 @@
+#############################################################
+#
+# googlefontdirectory
+#
+#############################################################
+
+GOOGLEFONTDIRECTORY_SITE = \
+	https://s3.amazonaws.com/joemaller_google_webfonts
+GOOGLEFONTDIRECTORY_SOURCE = googlewebfonts.tgz
+GOOGLEFONTDIRECTORY_LICENSE = OFLv1.1
+
+GOOGLEFONTDIRECTORY_FONTS = \
+	$(call qstrip,$(BR2_PACKAGE_GOOGLEFONTDIRECTORY_FONTS))
+
+define GOOGLEFONTDIRECTORY_INSTALL_TARGET_CMDS
+	for i in $(GOOGLEFONTDIRECTORY_FONTS); \
+	do \
+		$(INSTALL) -d $(TARGET_DIR)/usr/share/fonts/$$i && \
+		$(INSTALL) -m 0644 -t $(TARGET_DIR)/usr/share/fonts/$$i $(@D)/$$i/*.ttf; \
+	done
+endef
+
+define GOOGLEFONTDIRECTORY_UNINSTALL_TARGET_CMDS
+	rm -rf $(addprefix $(TARGET_DIR)/usr/share/fonts/,$(GOOGLEFONTDIRECTORY_FONTS))
+endef
+
+$(eval $(generic-package))