瀏覽代碼

linux: rename config option

Commit a4eef9a3959 (linux: introduce BR2_KERNEL_DTB_KEEP_DIRNAME)
introduced a new config option, but its name was not matching the
naming-scheme of the other config options.

Rename it.

We don't need legacy handling, because that config option was added very
recently and was never part of a release.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Yann E. MORIN 4 年之前
父節點
當前提交
d8e3e93969
共有 2 個文件被更改,包括 2 次插入2 次删除
  1. 1 1
      linux/Config.in
  2. 1 1
      linux/linux.mk

+ 1 - 1
linux/Config.in

@@ -407,7 +407,7 @@ config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
 	  You can provide a list of dts paths to copy and
 	  build, separated by spaces.
 
-config BR2_KERNEL_DTB_KEEP_DIRNAME
+config BR2_LINUX_KERNEL_DTB_KEEP_DIRNAME
 	bool "Keep the directory name of the Device Tree"
 	help
 	  If enabled, the device tree blobs keep their

+ 1 - 1
linux/linux.mk

@@ -381,7 +381,7 @@ define LINUX_INSTALL_DTB
 	$(foreach dtb,$(LINUX_DTBS), \
 		install -D \
 			$(or $(wildcard $(LINUX_ARCH_PATH)/boot/dts/$(dtb)),$(LINUX_ARCH_PATH)/boot/$(dtb)) \
-			$(1)/$(if $(BR2_KERNEL_DTB_KEEP_DIRNAME),$(dtb),$(notdir $(dtb)))
+			$(1)/$(if $(BR2_LINUX_KERNEL_DTB_KEEP_DIRNAME),$(dtb),$(notdir $(dtb)))
 	)
 endef
 endif # BR2_LINUX_KERNEL_APPENDED_DTB