Explorar el Código

toolchain/external: fix gdbserver install with Linaro 2015.08

In the latest Linaro toolchain, the gdbserver has moved (surprise!)
and is now located side-by-side with the toolchain executables.

This commit adds this path as a new location where to search for a
gdbserver, and while at it wraps the line that has become too long in
the process.

[Thomas: rework commit log according to Yann's suggestion.]

Signed-off-by: Trent Piepho <tpiepho@kymetacorp.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Trent Piepho hace 8 años
padre
commit
d7a92aa2fb
Se han modificado 1 ficheros con 4 adiciones y 1 borrados
  1. 4 1
      toolchain/toolchain-external/toolchain-external.mk

+ 4 - 1
toolchain/toolchain-external/toolchain-external.mk

@@ -645,7 +645,10 @@ define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS
 	if test "$(BR2_TOOLCHAIN_EXTERNAL_GDB_SERVER_COPY)" = "y"; then \
 		$(call MESSAGE,"Copying gdbserver") ; \
 		gdbserver_found=0 ; \
-		for d in $${ARCH_SYSROOT_DIR}/usr $${ARCH_SYSROOT_DIR}/../debug-root/usr $${ARCH_SYSROOT_DIR}/usr/$${ARCH_LIB_DIR} ; do \
+		for d in $${ARCH_SYSROOT_DIR}/usr \
+			 $${ARCH_SYSROOT_DIR}/../debug-root/usr \
+			 $${ARCH_SYSROOT_DIR}/usr/$${ARCH_LIB_DIR} \
+			 $(TOOLCHAIN_EXTERNAL_INSTALL_DIR); do \
 			if test -f $${d}/bin/gdbserver ; then \
 				install -m 0755 -D $${d}/bin/gdbserver $(TARGET_DIR)/usr/bin/gdbserver ; \
 				gdbserver_found=1 ; \