Pārlūkot izejas kodu

boot/uboot: fix environment image generation on big endian systems

As reported by Jeff Wittrock in bug #11396, the U-Boot environment
image checksum is invalid for big endian targets, because the test on
the BR2_ENDIAN Config.in option doesn't take into account that it is
double quoted.

The fix was provided by Jeff himself on bugzilla.

Fixes bug #11396.

Reported-by: Jeff Wittrock <jwittrock@faultrecorder.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit d6fcf044a747284df4eddaf106082ebb571976b3)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Thomas Petazzoni 5 gadi atpakaļ
vecāks
revīzija
d7749ec247
1 mainītis faili ar 1 papildinājumiem un 1 dzēšanām
  1. 1 1
      boot/uboot/uboot.mk

+ 1 - 1
boot/uboot/uboot.mk

@@ -263,7 +263,7 @@ define UBOOT_GENERATE_ENV_IMAGE
 		>$(@D)/buildroot-env.txt
 	$(HOST_DIR)/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
 		$(if $(BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT),-r) \
-		$(if $(filter BIG,$(BR2_ENDIAN)),-b) \
+		$(if $(filter "BIG",$(BR2_ENDIAN)),-b) \
 		-o $(BINARIES_DIR)/uboot-env.bin \
 		$(@D)/buildroot-env.txt
 endef