Browse Source

fs/squashfs: remove useless chmod

When that was added (in 975e30b, fs/squashfs: fix image file
permissions), the reasons were not quite explicit.

We are now forcing the umask, and various tests have shown that the mode
on the generated image file are correct without the chmod.

Remove it.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <peter@korsgaard.com>
Acked-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Yann E. MORIN 8 years ago
parent
commit
d1a2c0ed3c
1 changed files with 0 additions and 1 deletions
  1. 0 1
      fs/squashfs/squashfs.mk

+ 0 - 1
fs/squashfs/squashfs.mk

@@ -27,7 +27,6 @@ endif
 define ROOTFS_SQUASHFS_CMD
 	$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
 		$(ROOTFS_SQUASHFS_ARGS)
-	chmod 0644 $@
 endef
 
 $(eval $(call ROOTFS_TARGET,squashfs))