Browse Source

check-package: enable for toolchain/

The toolchain directory can benefit from this script to prevent common
mistakes when submitting patches.

In order to accomplish this:
Do not ignore anymore files from the toolchain/ directory.
Ignore this symbol:
 - BR_LIBC: defined by the buildroot toolchain, used by gcc-final.mk.

Ignore toolchain/toolchain-external/pkg-toolchain-external.mk as it
declares a package infra and not a package itself.
Ignore toolchain/helpers.mk as it contains only helper functions.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Ricardo Martincoski 6 years ago
parent
commit
bfc8dce467
2 changed files with 4 additions and 0 deletions
  1. 3 0
      utils/check-package
  2. 1 0
      utils/checkpackagelib/lib_mk.py

+ 3 - 0
utils/check-package

@@ -52,12 +52,15 @@ DO_CHECK_INTREE = re.compile("|".join([
     "linux/",
     "package/",
     "system/",
+    "toolchain/",
     ]))
 DO_NOT_CHECK_INTREE = re.compile("|".join([
     "boot/barebox/barebox\.mk$",
     "fs/common\.mk$",
     "package/doc-asciidoc\.mk$",
     "package/pkg-\S*\.mk$",
+    "toolchain/helpers\.mk$",
+    "toolchain/toolchain-external/pkg-toolchain-external\.mk$",
     ]))
 
 

+ 1 - 0
utils/checkpackagelib/lib_mk.py

@@ -159,6 +159,7 @@ class TypoInPackageVariable(_CheckFunction):
         "ACLOCAL_DIR",
         "ACLOCAL_HOST_DIR",
         "BR_CCACHE_INITIAL_SETUP",
+        "BR_LIBC",
         "BR_NO_CHECK_HASH_FOR",
         "LINUX_EXTENSIONS",
         "LINUX_POST_PATCH_HOOKS",