Browse Source

system: provide no default for custom skeleton path

Being custom means that our default one is not suitable to start with.
So there is no reason to offer it as the default path.

Add a check that it is not empty.

Add a separating empty line, for good measure, too.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@openwide.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Yann E. MORIN 8 years ago
parent
commit
b541b9ff94
2 changed files with 7 additions and 1 deletions
  1. 6 0
      package/skeleton/skeleton.mk
  2. 1 1
      system/Config.in

+ 6 - 0
package/skeleton/skeleton.mk

@@ -17,6 +17,12 @@ ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
 
 SKELETON_PATH = $(call qstrip,$(BR2_ROOTFS_SKELETON_CUSTOM_PATH))
 
+ifeq ($(BR_BUILDING),y)
+ifeq ($(SKELETON_PATH),)
+$(error No path specified for the custom skeleton)
+endif
+endif
+
 ifeq ($(BR2_ROOTFS_MERGED_USR),y)
 
 # Ensure the user has prepared a merged /usr.

+ 1 - 1
system/Config.in

@@ -184,9 +184,9 @@ config BR2_ROOTFS_SKELETON_CUSTOM
 endchoice
 
 if BR2_ROOTFS_SKELETON_CUSTOM
+
 config BR2_ROOTFS_SKELETON_CUSTOM_PATH
 	string "custom target skeleton path"
-	default "system/skeleton"
 	help
 	  Path to custom target skeleton.