Browse Source

netcat: force-remove nc link before install

The nc -> netcat symlink is not created if nc exists already, e.g.
from busybox.

For netcat itself this is not needed, it is always installed.

Cc: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Arnout Vandecappelle (Essensium/Mind) 6 years ago
parent
commit
b28d77789a
1 changed files with 9 additions and 2 deletions
  1. 9 2
      package/netcat/netcat.mk

+ 9 - 2
package/netcat/netcat.mk

@@ -9,10 +9,17 @@ NETCAT_SITE = http://downloads.sourceforge.net/project/netcat/netcat/$(NETCAT_VE
 NETCAT_LICENSE = GPL-2.0+
 NETCAT_LICENSE_FILES = COPYING
 
-# Ensure Busybox gets built/installed before, so that this package overrides
-# Busybox nc.
+# Ensure Busybox gets built/installed before, so that this package
+# overrides Busybox nc.
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 NETCAT_DEPENDENCIES += busybox
 endif
 
+# Netcat doesn't overwrite a pre-existing 'nc' (e.g. from busybox) so
+# force-remove it.
+define NETCAT_RMOVE_NC_LINK
+	rm -f $(TARGET_DIR)/usr/bin/nc
+endef
+NETCAT_PRE_INSTALL_TARGET_HOOKS += NETCAT_RMOVE_NC_LINK
+
 $(eval $(autotools-package))