Просмотр исходного кода

.gitlab-ci.yml: extend check-package test to hash files

Now that all issues in hash files have been fixed, let's try to make
sure we don't introduce new ones by checking regularly the hash files
issues in Gitlab CI.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni 6 лет назад
Родитель
Сommit
a59e4b0dd8
2 измененных файлов с 2 добавлено и 2 удалено
  1. 1 1
      .gitlab-ci.yml
  2. 1 1
      .gitlab-ci.yml.in

+ 1 - 1
.gitlab-ci.yml

@@ -32,7 +32,7 @@ check-DEVELOPERS:
 
 check-package:
     script:
-        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to

+ 1 - 1
.gitlab-ci.yml.in

@@ -32,7 +32,7 @@ check-DEVELOPERS:
 
 check-package:
     script:
-        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to