瀏覽代碼

package/sdl2: enable SSE only if it's supported by the target

Signed-off-by: Nicolas Robin <nrosfs@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Nicolas Robin 4 年之前
父節點
當前提交
a14a962983
共有 1 個文件被更改,包括 6 次插入0 次删除
  1. 6 0
      package/sdl2/sdl2.mk

+ 6 - 0
package/sdl2/sdl2.mk

@@ -30,6 +30,12 @@ else
 SDL2_CONF_OPTS += --disable-libudev
 endif
 
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+SDL2_CONF_OPTS += --enable-sse
+else
+SDL2_CONF_OPTS += --disable-sse
+endif
+
 ifeq ($(BR2_PACKAGE_SDL2_DIRECTFB),y)
 SDL2_DEPENDENCIES += directfb
 SDL2_CONF_OPTS += --enable-video-directfb