Browse Source

package/sdl2_net: add missing host-pkgconf dependency

The sdl2_net configure script uses pkg-config to finx sdl2. If it
doesn't find pkg-config, it tries to locate sdl2-config, and defaults
to /usr/bin/sdl2-config, which causes the build to fail with:

arm-linux-gcc: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/SDL2'

Fix this by adding host-pkgconf to the dependencies of sdl2_net. We
could have added the right autoconf cache variable to tell the
configure script where sdl2-config is located, but since pkg-config is
tried first, let's use that.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit c2a1bcb1b3e56c16a8433a516646d4eb8581fd91)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Thomas Petazzoni 5 years ago
parent
commit
9eace67f34
1 changed files with 1 additions and 1 deletions
  1. 1 1
      package/sdl2_net/sdl2_net.mk

+ 1 - 1
package/sdl2_net/sdl2_net.mk

@@ -10,6 +10,6 @@ SDL2_NET_SITE = http://www.libsdl.org/projects/SDL_net/release
 SDL2_NET_LICENSE = Zlib
 SDL2_NET_LICENSE_FILES = COPYING.txt
 SDL2_NET_INSTALL_STAGING = YES
-SDL2_NET_DEPENDENCIES = sdl2
+SDL2_NET_DEPENDENCIES = sdl2 host-pkgconf
 
 $(eval $(autotools-package))