Browse Source

boot/boot-wrapper-aarch64: add gicv3 support

This patch adds support for GICv3 (such as GIC-500).

Signed-off-by: Jan Kotas <jank@cadence.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Jan Kotas 4 years ago
parent
commit
95ed1429e6

+ 5 - 0
boot/boot-wrapper-aarch64/Config.in

@@ -38,4 +38,9 @@ config BR2_TARGET_BOOT_WRAPPER_AARCH64_PSCI
 	  Boot secondary SMP cores using PSCI firmware calls. If
 	  disabled, the spin-table method is used instead.
 
+config BR2_TARGET_BOOT_WRAPPER_AARCH64_GICV3
+	bool "Enable GICv3 instead of GICv2"
+	help
+	  Boot using GICv3 instead of GICv2.
+
 endif

+ 4 - 0
boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk

@@ -28,6 +28,10 @@ else
 BOOT_WRAPPER_AARCH64_CONF_OPTS += --disable-psci
 endif
 
+ifeq ($(BR2_TARGET_BOOT_WRAPPER_AARCH64_GICV3),y)
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --enable-gicv3
+endif
+
 # We need to convince the configure script that the Linux kernel tree
 # exists, as well as the DTB and the kernel Image. Even though those
 # are available on the build machine, the configure script uses