Forráskód Böngészése

package/rauc: prevent occurring the error when directory exists

Add -p argument that ignore that specified directory already exists.

Fixes:
 mkdir: cannot create directory ‘/home/bartekk/buildroot-2020.11-rc1/output/target/usr/lib/systemd/system/rauc.service.d’: File exists

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
(cherry picked from commit fefdd0511e99676aceb09403063f336e631d5067)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Bartosz Bilas 3 éve
szülő
commit
8c822798a5
1 módosított fájl, 1 hozzáadás és 1 törlés
  1. 1 1
      package/rauc/rauc.mk

+ 1 - 1
package/rauc/rauc.mk

@@ -31,7 +31,7 @@ RAUC_DEPENDENCIES += systemd
 endif
 
 define RAUC_INSTALL_INIT_SYSTEMD
-	mkdir $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
+	mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
 	printf '[Install]\nWantedBy=multi-user.target\n' \
 		>$(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d/buildroot-enable.conf
 endef