Browse Source

bump tinyalsa to latest version

Signed-off-by: Michel-FK <michel.stempin@funkey-project.com>
Michel-FK 3 years ago
parent
commit
873cabe3e6

+ 0 - 33
package/sdl_mixer/0003-Fix-include-of-modplug.h.patch

@@ -1,33 +0,0 @@
-From fb8e7c535a88838cc8ae364cd2a099df6316d3b0 Mon Sep 17 00:00:00 2001
-From: Paul Cercueil <paul@crapouillou.net>
-Date: Tue, 30 Apr 2019 23:12:15 +0200
-Subject: [PATCH] Fix include of modplug.h
-
-The include path should be <libmodplug/modplug.h>, since the library
-doesn't provide any specific include path in its pkg-config file.
-
-This patch was obtained from this bug report:
-https://bugzilla.libsdl.org/show_bug.cgi?id=4893
-
-Signed-off-by: Paul Cercueil <paul@crapouillou.net>
-
----
- music_modplug.h | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/music_modplug.h b/music_modplug.h
-index 92cbafd..49abbb0 100644
---- a/music_modplug.h
-+++ b/music_modplug.h
-@@ -1,6 +1,7 @@
- #ifdef MODPLUG_MUSIC
- 
--#include "modplug.h"
-+#include <libmodplug/modplug.h>
-+
- #include "SDL_rwops.h"
- #include "SDL_audio.h"
- #include "SDL_mixer.h"
--- 
-2.21.0.593.g511ec345e18
-

+ 0 - 34
package/sdl_mixer/0004-configure__set_macro_directory.patch

@@ -1,34 +0,0 @@
-# HG changeset patch
-# User "Yann E. MORIN" <yann.morin.1998@free.fr>
-# Date 1581183281 -3600
-#      Sat Feb 08 18:34:41 2020 +0100
-# Node ID 753a1f394620056c35790a571ff5f7c248445943
-# Parent  eb5f08bf9994bf5164ca68015f2e030c2c9dddcd
-configure: set macro directory
-
-Setting the macro directory in configure.in, rather than specifying it
-on the command line, ensures that it is properly searched in the correct
-order, and that autoreconf properly updates our macros with the newer
-system ones, if any.
-
-Fixes:
-    http://autobuild.buildroot.org/results/63a/63ae0bddb3c4436efe967c318e299047f496c5a5/build-end.log
-
-    libtool: Version mismatch error.  This is libtool 2.4.6, but the
-    libtool: definition of this LT_INIT comes from libtool 2.2.6.
-    libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
-    libtool: and run autoconf again.
-
-Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
-
-diff --git a/configure.in b/configure.in
---- a/configure.in
-+++ b/configure.in
-@@ -1,6 +1,7 @@
- dnl Process this file with autoconf to produce a configure script.
- AC_INIT(README)
- AC_CONFIG_AUX_DIR(build-scripts)
-+AC_CONFIG_MACRO_DIR([acinclude])
- 
- dnl Set various version strings - taken gratefully from the GTk sources
- 

+ 0 - 3
package/sdl_mixer/sdl_mixer.hash

@@ -1,3 +0,0 @@
-# Locally calculated
-sha256	1644308279a975799049e4826af2cfc787cad2abb11aa14562e402521f86992a	SDL_mixer-1.2.12.tar.gz
-sha256	bc4c3bc32b311044d81c32b5e5402a6bc971a3b235850bb63445ec14bb6fe59e	COPYING

+ 0 - 36
package/tinyalsa/0002-interval.h-add-missing-header.patch

@@ -1,36 +0,0 @@
-From 685e530d8a0063134642371eaacd01fee2f62d85 Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Fri, 2 Jun 2017 12:19:03 +0300
-Subject: [PATCH] interval.h: add missing header
-
-The ssize_t type requires the unistd.h header. This fixes build with musl
-libc:
-
-In file included from ../include/tinyalsa/limits.h:32:0,
-                 from limits.c:1:
-../include/tinyalsa/interval.h:38:2: error: unknown type name 'ssize_t'
-  ssize_t max;
-  ^
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-Upstream status: https://github.com/tinyalsa/tinyalsa/pull/98
-
- include/tinyalsa/interval.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/tinyalsa/interval.h b/include/tinyalsa/interval.h
-index 3f6f3dce5d90..068571df5a63 100644
---- a/include/tinyalsa/interval.h
-+++ b/include/tinyalsa/interval.h
-@@ -30,6 +30,7 @@
- #define TINYALSA_INTERVAL_H
- 
- #include <stdlib.h>
-+#include <unistd.h>
- 
- /** A closed range signed interval. */
- 
--- 
-2.11.0
-

+ 1 - 1
package/tinyalsa/tinyalsa.hash

@@ -1,3 +1,3 @@
 # locally computed
-sha256  d92b438cea348ae316c4b2cbf367b4f01ed821a947e6a34d813624e9e3c936c1  tinyalsa-1.1.1.tar.gz
+sha256  3c30e2ee32af81f6dfc1d1f396f9ee3309791ade2b29304e695eeb37669a8c76  tinyalsa-69b9891.tar.gz
 sha256  ca2b89a68c33fba3c8bcaec96f32907e2ede0eb33688ae61d29ec49732158f6d  NOTICE

+ 4 - 23
package/tinyalsa/tinyalsa.mk

@@ -4,30 +4,11 @@
 #
 ################################################################################
 
-TINYALSA_VERSION = 1.1.1
-TINYALSA_SITE = $(call github,tinyalsa,tinyalsa,$(TINYALSA_VERSION))
+TINYALSA_VERSION = 30d4711
+FCEUX_SITE_METHOD = git
+FCEUX_SITE = https://github.com/FunKey-Project/tinyalsa.git
 TINYALSA_LICENSE = BSD-3-Clause
 TINYALSA_LICENSE_FILES = NOTICE
 TINYALSA_INSTALL_STAGING = YES
 
-define TINYALSA_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D)
-endef
-
-define TINYALSA_INSTALL_STAGING_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) \
-		-C $(@D) \
-		PREFIX="/usr" \
-		CROSS_COMPILE="$(TARGET_CROSS)" \
-		DESTDIR="$(STAGING_DIR)" install
-endef
-
-define TINYALSA_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) \
-		-C $(@D) \
-		PREFIX="/usr" \
-		CROSS_COMPILE="$(TARGET_CROSS)" \
-		DESTDIR="$(TARGET_DIR)" install
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))