Browse Source

package/coreutils: split COREUTILS_CLEANUP and use better names

The COREUTILS_CLEANUP macro naming is a bit weird. In addition, it
does two unrelated things, and the introduction of support for
building coreutils as individual binaries will require splitting it
up.

So let's do this split as a preparation commit, and use better names
for both resulting macros.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Thomas Petazzoni 5 years ago
parent
commit
840cda9115
1 changed files with 8 additions and 5 deletions
  1. 8 5
      package/coreutils/coreutils.mk

+ 8 - 5
package/coreutils/coreutils.mk

@@ -110,14 +110,17 @@ ifeq ($(BR2_STATIC_LIBS),y)
 COREUTILS_CONF_OPTS += --enable-no-install-program=stdbuf
 endif
 
-define COREUTILS_CLEANUP
-	# link for archaic shells
+# link for archaic shells
+define COREUTILS_CREATE_TEST_SYMLINK
 	ln -fs coreutils $(TARGET_DIR)/usr/bin/[
-	# gnu thinks chroot is in bin, debian thinks it's in sbin
+endef
+COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_CREATE_TEST_SYMLINK
+
+# gnu thinks chroot is in bin, debian thinks it's in sbin
+define COREUTILS_FIX_CHROOT_LOCATION
 	rm -f $(TARGET_DIR)/usr/bin/chroot
 	ln -sf ../bin/coreutils $(TARGET_DIR)/usr/sbin/chroot
 endef
-
-COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_CLEANUP
+COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_FIX_CHROOT_LOCATION
 
 $(eval $(autotools-package))