Procházet zdrojové kódy

package/gst-omx: bump version to 1.18.0 and convert to meson

- change home page url to https

- drop bellagio support (as the project is no longer maintained
  no update since 2011, see [1])

[1] http://omxil.sourceforge.net

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Peter Seiderer před 3 roky
rodič
revize
7e6f4e56cd

+ 1 - 1
package/gstreamer1/gst-omx/Config.in

@@ -5,7 +5,7 @@ config BR2_PACKAGE_GST_OMX
 	help
 	  GStreamer plug-in to use OpenMAX API.
 
-	  http://cgit.freedesktop.org/gstreamer/gst-omx
+	  https://cgit.freedesktop.org/gstreamer/gst-omx
 
 comment "gst-omx requires a OpenMAX implementation"
 	depends on !BR2_PACKAGE_HAS_LIBOPENMAX

+ 3 - 3
package/gstreamer1/gst-omx/gst-omx.hash

@@ -1,3 +1,3 @@
-# From https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-1.16.2.tar.xz.sha256sum
-sha256 11ed411a2eba75610d72331eeb14ff05e2df28f4fd05cb69225a88bec6d27439 gst-omx-1.16.2.tar.xz
-sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
+# From https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-1.18.0.tar.xz.sha256sum
+sha256  302c65e04578991364f7605e04cfb54dfd75268d51080d35f221ee1a8b341fad  gst-omx-1.18.0.tar.xz
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING

+ 10 - 17
package/gstreamer1/gst-omx/gst-omx.mk

@@ -4,33 +4,26 @@
 #
 ################################################################################
 
-GST_OMX_VERSION = 1.16.2
+GST_OMX_VERSION = 1.18.0
 GST_OMX_SOURCE = gst-omx-$(GST_OMX_VERSION).tar.xz
 GST_OMX_SITE = https://gstreamer.freedesktop.org/src/gst-omx
 
 GST_OMX_LICENSE = LGPL-2.1
 GST_OMX_LICENSE_FILES = COPYING
 
+GST_OMX_CONF_OPTS = \
+	-Dexamples=disabled \
+	-Dtests=disabled \
+	-Dtools=disabled \
+	-Ddoc=disabled
+
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 GST_OMX_VARIANT = rpi
-GST_OMX_CONF_ENV = \
-	CFLAGS="$(TARGET_CFLAGS) \
-		-I$(STAGING_DIR)/usr/include/IL \
-		-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
-		-I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux"
-else ifeq ($(BR2_PACKAGE_BELLAGIO),y)
-GST_OMX_VARIANT = bellagio
-GST_OMX_CONF_ENV = \
-	CFLAGS="$(TARGET_CFLAGS) \
-		-DOMX_VERSION_MAJOR=1 \
-		-DOMX_VERSION_MINOR=1 \
-		-DOMX_VERSION_REVISION=2 \
-		-DOMX_VERSION_STEP=0"
-else
+GST_OMX_CONF_OPTS += -Dheader_path=$(STAGING_DIR)/usr/include/IL
 GST_OMX_VARIANT = generic
 endif
 
-GST_OMX_CONF_OPTS += --with-omx-target=$(GST_OMX_VARIANT)
+GST_OMX_CONF_OPTS += -Dtarget=$(GST_OMX_VARIANT)
 
 GST_OMX_DEPENDENCIES = gstreamer1 gst1-plugins-base libopenmax
 
@@ -42,4 +35,4 @@ endef
 
 GST_OMX_POST_PATCH_HOOKS += GST_OMX_FIXUP_CONFIG_PATHS
 
-$(eval $(autotools-package))
+$(eval $(meson-package))