Browse Source

tools: rename to 'utils'

After some discussion, we found out that "tools" has the four first
letters identical to the "toolchain" subfolder, which makes it a bit
unpractical with tab-completion. So, this commit renames "tools" to
"utils", which is more tab-completion-friendly.

This has been discussed with Arnout and Yann.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni 6 years ago
parent
commit
7ca9fc3170

+ 4 - 4
docs/manual/adding-packages-tips.txt

@@ -45,7 +45,7 @@ continuously test random configurations. However, these only build the
 `master` branch of the git tree, and your new fancy package is not yet
 there.
 
-Buildroot provides a script in +tools/test-pkg+ that uses the same base
+Buildroot provides a script in +utils/test-pkg+ that uses the same base
 configurations as used by the autobuilders so you can test your package
 in the same conditions.
 
@@ -74,7 +74,7 @@ Then run the +test-pkg+ script, by telling it what config snippet to use
 and what package to test:
 
 ----
-$ ./tools/test-pkg -c libcurl.config -p libcurl
+$ ./utils/test-pkg -c libcurl.config -p libcurl
 ----
 
 This will try to build your package against all the toolchains used
@@ -83,7 +83,7 @@ too long to do so). The output lists all toolchains and the corresponding
 result (excerpt, results are fake):
 
 ----
-$ ./tools/test-pkg -c libcurl.config -p libcurl
+$ ./utils/test-pkg -c libcurl.config -p libcurl
                 armv5-ctng-linux-gnueabi [ 1/11]: OK
               armv7-ctng-linux-gnueabihf [ 2/11]: OK
                         br-aarch64-glibc [ 3/11]: SKIPPED
@@ -124,7 +124,7 @@ The +test-pkg+ script accepts a few options, for which you can get some
 help by running:
 
 ----
-$ ./tools/test-pkg -h
+$ ./utils/test-pkg -h
 ----
 
 [[github-download-url]]

+ 1 - 1
docs/manual/contribute.txt

@@ -295,7 +295,7 @@ information). This tool reads your patches and outputs the appropriate
 +git send-email+ command to use:
 
 ---------------------
-$ ./tools/get-developers outgoing/*
+$ ./utils/get-developers outgoing/*
 ---------------------
 
 Use the output of +get-developers+ to send your patches:

+ 1 - 1
docs/manual/writing-rules.txt

@@ -146,6 +146,6 @@ syntax, refer to http://www.methods.co.nz/asciidoc/userguide.html[].
 
 === Support scripts
 
-Some scripts in the +support/+ and +tools/+ directories are written in
+Some scripts in the +support/+ and +utils/+ directories are written in
 Python and should follow the
 https://www.python.org/dev/peps/pep-0008/[PEP8 Style Guide for Python Code].

+ 1 - 1
support/scripts/pkg-stats

@@ -337,7 +337,7 @@ for i in $(find boot/ linux/ package/ toolchain/ -name '*.mk' | sort) ; do
     fi
 
     file_list=$(find ${package_dir} -name '*.mk' -o -name '*.in*' -o -name '*.hash')
-    nwarnings=$(./tools/check-package ${file_list} 2>&1 | sed '/\([0-9]*\) warnings generated/!d; s//\1/')
+    nwarnings=$(./utils/check-package ${file_list} 2>&1 | sed '/\([0-9]*\) warnings generated/!d; s//\1/')
     if [ ${nwarnings} -eq 0 ] ; then
 	echo "<td class=\"centered correct\">${nwarnings}</td>"
     else

+ 0 - 0
tools/brmake → utils/brmake


+ 1 - 1
tools/check-package → utils/check-package

@@ -1,5 +1,5 @@
 #!/usr/bin/env python
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 
 from __future__ import print_function
 import argparse

+ 0 - 0
tools/checkpackagelib/__init__.py → utils/checkpackagelib/__init__.py


+ 1 - 1
tools/checkpackagelib/base.py → utils/checkpackagelib/base.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 
 
 class _CheckFunction(object):

+ 1 - 1
tools/checkpackagelib/lib.py → utils/checkpackagelib/lib.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 
 from base import _CheckFunction
 

+ 1 - 1
tools/checkpackagelib/lib_config.py → utils/checkpackagelib/lib_config.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 # Kconfig generates errors if someone introduces a typo like "boool" instead of
 # "bool", so below check functions don't need to check for things already
 # checked by running "make menuconfig".

+ 1 - 1
tools/checkpackagelib/lib_hash.py → utils/checkpackagelib/lib_hash.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 # The validity of the hashes itself is checked when building, so below check
 # functions don't need to check for things already checked by running
 # "make package-dirclean package-source".

+ 1 - 1
tools/checkpackagelib/lib_mk.py → utils/checkpackagelib/lib_mk.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 # There are already dependency checks during the build, so below check
 # functions don't need to check for things already checked by exploring the
 # menu options using "make menuconfig" and by running "make" with appropriate

+ 1 - 1
tools/checkpackagelib/lib_patch.py → utils/checkpackagelib/lib_patch.py

@@ -1,4 +1,4 @@
-# See tools/checkpackagelib/readme.txt before editing this file.
+# See utils/checkpackagelib/readme.txt before editing this file.
 # The format of the patch files is tested during the build, so below check
 # functions don't need to check for things already checked by running
 # "make package-dirclean package-patch".

+ 5 - 5
tools/checkpackagelib/readme.txt → utils/checkpackagelib/readme.txt

@@ -57,19 +57,19 @@ Some hints when changing this code:
 Usage examples:
 - to get a list of check functions that would be called without actually
   calling them you can use the --dry-run option:
-$ tools/check-package --dry-run package/yourfavorite/*
+$ utils/check-package --dry-run package/yourfavorite/*
 
 - when you just added a new check function, e.g. Something, check how it behaves
   for all current packages:
-$ tools/check-package --include-only Something $(find package -type f)
+$ utils/check-package --include-only Something $(find package -type f)
 
 - the effective processing time (when the .pyc were already generated and all
   files to be processed are cached in the RAM) should stay in the order of few
   seconds:
-$ tools/check-package $(find package -type f) >/dev/null ; \
-  time tools/check-package $(find package -type f) >/dev/null
+$ utils/check-package $(find package -type f) >/dev/null ; \
+  time utils/check-package $(find package -type f) >/dev/null
 
 - vim users can navigate the warnings (most editors probably have similar
   function) since warnings are generated in the form 'path/file:line: warning':
 $ find package/ -name 'Config.*' > filelist && vim -c \
-  'set makeprg=tools/check-package\ $(cat\ filelist)' -c make -c copen
+  'set makeprg=utils/check-package\ $(cat\ filelist)' -c make -c copen

+ 0 - 0
tools/get-developers → utils/get-developers


+ 0 - 0
tools/getdeveloperlib.py → utils/getdeveloperlib.py


+ 0 - 0
tools/readme.txt → utils/readme.txt


+ 0 - 0
tools/scancpan → utils/scancpan


+ 0 - 0
tools/scanpypi → utils/scanpypi


+ 0 - 0
tools/size-stats-compare → utils/size-stats-compare


+ 0 - 0
tools/test-pkg → utils/test-pkg