Explorar o código

pngquant: doesn't support building with ccache

pngquant's homegrown configure script doesn't understand CC with a
space, so we can't use ccache with it. Only the host variant is
affected: for the target, we call ccache from the toolchain-wrapper so
it's transparent to the configure script.

This wasn't seen in the autobuilders since they never enable
BR2_CCACHE.

To test, use any configuration and do
make BR2_CCACHE=y host-pngquant

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
(cherry picked from commit 4a6168db97db6501af42e96091da3218ae64d5c1)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Arnout Vandecappelle %!s(int64=7) %!d(string=hai) anos
pai
achega
7c748b5408
Modificáronse 1 ficheiros con 1 adicións e 0 borrados
  1. 1 0
      package/pngquant/pngquant.mk

+ 1 - 0
package/pngquant/pngquant.mk

@@ -36,6 +36,7 @@ endef
 define HOST_PNGQUANT_CONFIGURE_CMDS
 	(cd $(@D) && \
 		$(HOST_CONFIGURE_OPTS) \
+		CC=$(HOSTCC_NOCCACHE) \
 		./configure --prefix=$(HOST_DIR)/usr \
 		--without-lcms2 \
 	)