Browse Source

fs: squashfs: Add config option to pass nopad parameter to mksquashfs

Add an option to enable/disable padding to a multiple of 4k. Padding is
the default as it also was the past default behaviour.

Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
Signed-off-by: Heiko Stuebner <heiko.stuebner@theobroma-systems.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Christoph Muellner 3 years ago
parent
commit
7c57c1952f
2 changed files with 12 additions and 0 deletions
  1. 8 0
      fs/squashfs/Config.in
  2. 4 0
      fs/squashfs/squashfs.mk

+ 8 - 0
fs/squashfs/Config.in

@@ -5,6 +5,13 @@ config BR2_TARGET_ROOTFS_SQUASHFS
 
 if BR2_TARGET_ROOTFS_SQUASHFS
 
+config BR2_TARGET_ROOTFS_SQUASHFS_PAD
+	bool "pad to a 4K boundary"
+	default y # legacy was always ON
+	help
+	  Say 'y' here (the default) to pad the the filesystem image
+	  to a 4K boundary. Say 'n' to disable padding.
+
 choice
 	prompt "Compression algorithm"
 	default BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
@@ -31,4 +38,5 @@ config BR2_TARGET_ROOTFS_SQUASHFS4_ZSTD
 	bool "zstd"
 
 endchoice
+
 endif

+ 4 - 0
fs/squashfs/squashfs.mk

@@ -8,6 +8,10 @@ ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
 
 ROOTFS_SQUASHFS_ARGS = -noappend -processors $(PARALLEL_JOBS)
 
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_PAD),)
+ROOTFS_SQUASHFS_ARGS += -nopad
+endif
+
 ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZ4),y)
 ROOTFS_SQUASHFS_ARGS += -comp lz4 -Xhc
 else ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)