Browse Source

boost: bump to version 1.66.0

Drop the metaparse module as it is header only library now. No need for
legacy handling as the module is available unconditionally in Boost.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Jörg Krause 6 years ago
parent
commit
735158d55a
3 changed files with 3 additions and 12 deletions
  1. 0 8
      package/boost/Config.in
  2. 2 2
      package/boost/boost.hash
  3. 1 2
      package/boost/boost.mk

+ 0 - 8
package/boost/Config.in

@@ -192,14 +192,6 @@ config BR2_PACKAGE_BOOST_MATH
 	  Octonions, like quaternions, are a relative of complex
 	  numbers.
 
-config BR2_PACKAGE_BOOST_METAPARSE
-	bool "boost-metaparse"
-	depends on BR2_USE_MMU # boost-test
-	select BR2_PACKAGE_BOOST_TEST
-	help
-	  A library for generating compile time parsers parsing embedded
-	  DSL code as part of the C++ compilation process
-
 config BR2_PACKAGE_BOOST_MPI
 	bool "boost-mpi"
 	help

+ 2 - 2
package/boost/boost.hash

@@ -1,5 +1,5 @@
-# From http://www.boost.org/users/history/version_1_65_1.html
-sha256 9807a5d16566c57fd74fb522764e0b134a8bbe6b6e8967b83afefd30dcd3be81  boost_1_65_1.tar.bz2
+# From http://www.boost.org/users/history/version_1_66_0.html
+sha256 5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9  boost_1_66_0.tar.bz2
 
 # Locally computed
 sha256 c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566  LICENSE_1_0.txt

+ 1 - 2
package/boost/boost.mk

@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BOOST_VERSION = 1.65.1
+BOOST_VERSION = 1.66.0
 BOOST_SOURCE = boost_$(subst .,_,$(BOOST_VERSION)).tar.bz2
 BOOST_SITE = http://downloads.sourceforge.net/project/boost/boost/$(BOOST_VERSION)
 BOOST_INSTALL_STAGING = YES
@@ -34,7 +34,6 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_IOSTREAMS),,iostreams)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
-BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_METAPARSE),,metaparse)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PYTHON),,python)