ソースを参照

package/systemd: add a menu entry to enable portable services

Signed-off-by: Francois Gervais <fgervais@distech-controls.com>
Reviewed-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Francois Gervais 3 年 前
コミット
70f35db9f7
2 ファイル変更24 行追加1 行削除
  1. 18 0
      package/systemd/Config.in
  2. 6 1
      package/systemd/systemd.mk

+ 18 - 0
package/systemd/Config.in

@@ -343,6 +343,24 @@ comment "polkit support needs a toolchain with C++, wchar, NPTL, gcc >= 4.9"
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
 		!BR2_USE_WCHAR
 
+config BR2_PACKAGE_SYSTEMD_PORTABLED
+	bool "enable portable services"
+	help
+	  Portable services are systemd services that can be dynamically
+	  attached and detached from the system.
+
+	  These services must come with their own root directory which
+	  they are bound to through an automatically generated drop-in.
+
+	  They also have restrictions applied by the host system in the
+	  form of profiles.
+
+	  This functionality is provided by the system service
+	  systemd-portabled along with the corresponding CLI
+	  portablectl.
+
+	  https://systemd.io/PORTABLE_SERVICES/
+
 config BR2_PACKAGE_SYSTEMD_QUOTACHECK
 	bool "enable quotacheck tools"
 	help

+ 6 - 1
package/systemd/systemd.mk

@@ -33,7 +33,6 @@ SYSTEMD_CONF_OPTS += \
 	-Dman=false \
 	-Dmount-path=/usr/bin/mount \
 	-Dnss-systemd=true \
-	-Dportabled=false \
 	-Dquotacheck-path=/usr/sbin/quotacheck \
 	-Dquotaon-path=/usr/sbin/quotaon \
 	-Drootlibdir='/usr/lib' \
@@ -417,6 +416,12 @@ else
 SYSTEMD_CONF_OPTS += -Dpolkit=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_PORTABLED),y)
+SYSTEMD_CONF_OPTS += -Dportabled=true
+else
+SYSTEMD_CONF_OPTS += -Dportabled=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += -Dnetworkd=true
 SYSTEMD_NETWORKD_USER = systemd-network -1 systemd-network -1 * - - - systemd Network Management