Parcourir la source

afboot-stm32: new package

This is a _very_ small bootloader for STM32 platforms.

At submission afboot-stm32 supports the following boards:

  stm32429i-eval
  stm32746g-eval
  stm32f429i-disco
  stm32f469i-disco

Signed-off-by: Lee Jones <lee.jones@linaro.org>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: fix commit title, add dependency on BR2_arm.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Lee Jones il y a 8 ans
Parent
commit
70c26b8c53

+ 1 - 0
boot/Config.in

@@ -1,5 +1,6 @@
 menu "Bootloaders"
 
+source "boot/afboot-stm32/Config.in"
 source "boot/at91bootstrap/Config.in"
 source "boot/at91bootstrap3/Config.in"
 source "boot/at91dataflashboot/Config.in"

+ 7 - 0
boot/afboot-stm32/Config.in

@@ -0,0 +1,7 @@
+config BR2_TARGET_AFBOOT_STM32
+	bool "afboot-stm32"
+	depends on BR2_arm
+	help
+	  afboot-stm32 is a very small bootloader for STM32 platforms
+
+	  https://github.com/mcoquelin-stm32/afboot-stm32

+ 2 - 0
boot/afboot-stm32/afboot-stm32.hash

@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 dbd715c8b99f7d266f74a04707a4dac76b75b31321f24dee5256a6348260530c  afboot-stm32-v0.1.tar.gz

+ 18 - 0
boot/afboot-stm32/afboot-stm32.mk

@@ -0,0 +1,18 @@
+################################################################################
+#
+# afboot-stm32
+#
+################################################################################
+
+AFBOOT_STM32_VERSION = v0.1
+AFBOOT_STM32_SITE = $(call github,mcoquelin-stm32,afboot-stm32,$(AFBOOT_STM32_VERSION))
+
+define AFBOOT_STM32_BUILD_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) all
+endef
+
+define AFBOOT_STM32_INSTALL_TARGET_CMDS
+	$(INSTALL) -m 0755 $(@D)/stm32*.bin $(BINARIES_DIR)
+endef
+
+$(eval $(generic-package))