Pārlūkot izejas kodu

rfkill: remove package

The rfkill program has been incorporated to the util-linux package.

The new implementation is based upon, and backward compatible with, the
original rfkill from Johannes Berg and Marcel Holtmann.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Carlos Santos 6 gadi atpakaļ
vecāks
revīzija
6c10e40d23

+ 8 - 0
Config.in.legacy

@@ -145,6 +145,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.11"
 
+config BR2_PACKAGE_RFKILL
+	bool "rfkill package removed"
+	select BR2_LEGACY
+	select BR2_PACKAGE_UTIL_LINUX
+	select BR2_PACKAGE_UTIL_LINUX_RFKILL
+	help
+	  The rfkill program is now provided by the util-linux package.
+
 config BR2_PACKAGE_UTIL_LINUX_RESET
 	bool "util-linux reset option removed"
 	select BR2_LEGACY

+ 0 - 1
DEVELOPERS

@@ -1640,7 +1640,6 @@ N:	Vinicius Tinti <viniciustinti@gmail.com>
 F:	package/python-thrift/
 
 N:	Volkov Viacheslav <sv99@inbox.ru>
-F:	package/rfkill/
 F:	package/v4l2grab/
 F:	package/zbar/
 

+ 0 - 1
package/Config.in

@@ -477,7 +477,6 @@ endmenu
 	source "package/pru-software-support/Config.in"
 	source "package/pulseview/Config.in"
 	source "package/read-edid/Config.in"
-	source "package/rfkill/Config.in"
 	source "package/rng-tools/Config.in"
 	source "package/rpi-userland/Config.in"
 	source "package/rs485conf/Config.in"

+ 2 - 2
package/aircrack-ng/Config.in

@@ -11,8 +11,8 @@ config BR2_PACKAGE_AIRCRACK_NG
 	help
 	  A set of tools for auditing wireless networks
 
-	  For complete functionality, also select ethtool, iw, rfkill,
-	  util-linux utilities, and wireless_tools.
+	  For complete functionality, also select ethtool, iw,
+	  util-linux (utilities and rfkill), and wireless_tools.
 
 	  http://www.aircrack-ng.org/
 

+ 0 - 7
package/rfkill/Config.in

@@ -1,7 +0,0 @@
-config BR2_PACKAGE_RFKILL
-	bool "rfkill"
-	help
-	  rfkill is a small userspace tool to query the state of the
-	  rfkill switches.
-
-	  https://wireless.wiki.kernel.org/en/users/documentation/rfkill

+ 0 - 2
package/rfkill/rfkill.hash

@@ -1,2 +0,0 @@
-# From: https://www.kernel.org/pub/software/network/rfkill/sha256sums.asc
-sha256	e0ae3004215e39a6c5c36e0726558740728d16f67ebdb8bea621250f6091d86a  rfkill-0.5.tar.xz

+ 0 - 22
package/rfkill/rfkill.mk

@@ -1,22 +0,0 @@
-################################################################################
-#
-# rfkill
-#
-################################################################################
-
-RFKILL_VERSION = 0.5
-RFKILL_SOURCE = rfkill-$(RFKILL_VERSION).tar.xz
-RFKILL_SITE = https://www.kernel.org/pub/software/network/rfkill
-RFKILL_LICENSE = ISC
-RFKILL_LICENSE_FILES = COPYING
-
-define RFKILL_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-		VERSION_SUFFIX="br"
-endef
-
-define RFKILL_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))