浏览代码

package/pkg-qmake.mk: only add qt5base dependency when we're not qt5base

As we are about to convert qt5base to the qmake-package
infrastructure, we need to avoid a circular dependency: the qt5base
package itself should not depend on qt5base.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Thomas Petazzoni 4 年之前
父节点
当前提交
52dedbea62
共有 1 个文件被更改,包括 2 次插入0 次删除
  1. 2 0
      package/pkg-qmake.mk

+ 2 - 0
package/pkg-qmake.mk

@@ -40,7 +40,9 @@ $(2)_MAKE_OPTS			?=
 $(2)_INSTALL_STAGING_OPTS	?= install
 $(2)_INSTALL_TARGET_OPTS	?= $$($(2)_INSTALL_STAGING_OPTS)
 
+ifneq ($(1),qt5base)
 $(2)_DEPENDENCIES 		+= qt5base
+endif
 
 #
 # Configure step. Only define it if not already defined by the package