Browse Source

mesa3d: requires host-libxml2 and host-python to generate some files

mesa3d now generates some C files at build time (related to the OpenGL
API) from XML files. This generation process is done using Python
scripts that require the libxml2 Python module.

Patch based on the initial work of Will Wagner (Thanks Will).

Signed-off-by: Vellemans Noel <noel.vellemans@visionbms.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Vellemans Noel 11 years ago
parent
commit
517e5395a1
2 changed files with 4 additions and 1 deletions
  1. 1 0
      package/x11r7/mesa3d/Config.in
  2. 3 1
      package/x11r7/mesa3d/mesa3d.mk

+ 1 - 0
package/x11r7/mesa3d/Config.in

@@ -7,6 +7,7 @@ config BR2_PACKAGE_MESA3D
 	select BR2_PACKAGE_XPROTO_DRI2PROTO
 	select BR2_PACKAGE_LIBDRM
 	select BR2_PACKAGE_EXPAT
+	select BR2_PACKAGE_HOST_LIBXML2_PYTHON
 	depends on BR2_PACKAGE_XSERVER_xorg
 	depends on BR2_INSTALL_LIBSTDCPP
 	help

+ 3 - 1
package/x11r7/mesa3d/mesa3d.mk

@@ -28,6 +28,8 @@ MESA3D_DEPENDENCIES = \
 	xproto_dri2proto \
 	libdrm \
 	expat \
-	host-xutil_makedepend
+	host-xutil_makedepend \
+	host-libxml2 \
+	host-python
 
 $(eval $(autotools-package))