Quellcode durchsuchen

check-package: enable for linux/

This directory can benefit from this script to prevent common mistakes
when submitting patches.

In order to accomplish this:
Do not ignore anymore files from the linux/ directory.
Ignore missing LINUX_EXT_ prefix as the variables for linux extensions
do not use it.
Ignore this symbol:
 - LINUX_EXTENSIONS: defined by each linux extension, used by
   linux/linux.mk.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Ricardo Martincoski vor 6 Jahren
Ursprung
Commit
4d39f5876d
2 geänderte Dateien mit 4 neuen und 0 gelöschten Zeilen
  1. 1 0
      utils/check-package
  2. 3 0
      utils/checkpackagelib/lib_mk.py

+ 1 - 0
utils/check-package

@@ -49,6 +49,7 @@ DO_CHECK_INTREE = re.compile("|".join([
     "arch/",
     "boot/",
     "fs/",
+    "linux/",
     "package/",
     "system/",
     ]))

+ 3 - 0
utils/checkpackagelib/lib_mk.py

@@ -160,6 +160,7 @@ class TypoInPackageVariable(_CheckFunction):
         "ACLOCAL_HOST_DIR",
         "BR_CCACHE_INITIAL_SETUP",
         "BR_NO_CHECK_HASH_FOR",
+        "LINUX_EXTENSIONS",
         "LINUX_POST_PATCH_HOOKS",
         "LINUX_TOOLS",
         "LUA_RUN",
@@ -179,6 +180,8 @@ class TypoInPackageVariable(_CheckFunction):
         package = package.replace("-", "_").upper()
         # linux tools do not use LINUX_TOOL_ prefix for variables
         package = package.replace("LINUX_TOOL_", "")
+        # linux extensions do not use LINUX_EXT_ prefix for variables
+        package = package.replace("LINUX_EXT_", "")
         self.package = package
         self.REGEX = re.compile("^(HOST_|ROOTFS_)?({}_[A-Z0-9_]+)".format(package))
         self.FIND_VIRTUAL = re.compile(