Browse Source

package/ibm-sw-tpm2: new package

This project is an implementation of the TCG TPM 2.0 specification. It
is based on the TPM specification Parts 3 and 4 source code donated by
Microsoft, with additional files to complete the implementation.

Signed-off-by: Philippe Reynes <philippe.reynes@softathome.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Philippe Reynes 4 years ago
parent
commit
43162eaaa1

+ 3 - 0
DEVELOPERS

@@ -2092,6 +2092,9 @@ F:	package/lttng-tools/
 F:	package/python-ipython/
 F:	package/liburcu/
 
+N:	Philippe Reynes <philippe.reynes@softathome.com>
+F:	package/ibm-sw-tpm2/
+
 N:	Pierre Crokaert <pct@crookies.net>
 F:	board/hardkernel/odroidxu4/
 F:	configs/odroidxu4_defconfig

+ 1 - 0
package/Config.in

@@ -2338,6 +2338,7 @@ menu "System tools"
 	source "package/ftop/Config.in"
 	source "package/getent/Config.in"
 	source "package/htop/Config.in"
+	source "package/ibm-sw-tpm2/Config.in"
 	source "package/initscripts/Config.in"
 	source "package/iotop/Config.in"
 	source "package/iprutils/Config.in"

+ 16 - 0
package/ibm-sw-tpm2/Config.in

@@ -0,0 +1,16 @@
+config BR2_PACKAGE_IBM_SW_TPM2
+	bool "ibm-sw-tpm2"
+	depends on !BR2_STATIC_LIBS # ibm-sw-tpm2
+	select BR2_PACKAGE_OPENSSL
+	# libressl is not supported
+	select BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL
+	help
+	  This project is an implementation of the TCG TPM 2.0
+	  specification. It is based on the TPM specification Parts 3
+	  and 4 source code donated by Microsoft, with additional
+	  files to complete the implementation.
+
+	  https://sourceforge.net/projects/ibmswtpm2/
+
+comment "ibm-sw-tpm2 needs a toolchain w/ dynamic library"
+	depends on BR2_STATIC_LIBS

+ 6 - 0
package/ibm-sw-tpm2/ibm-sw-tpm2.hash

@@ -0,0 +1,6 @@
+# from https://sourceforge.net/projects/ibmswtpm2/files
+sha1  a2a5335024a2edc1739f08b99e716fa355be627d  ibmtpm1563.tar.gz
+md5  13013612b3a13dc935fefe1a5684179c  ibmtpm1563.tar.gz
+# Locally computed:
+sha256  fc3a17f8315c1f47670764f2384943afc0d3ba1e9a0422dacb08d455733bd1e9  ibmtpm1563.tar.gz
+sha256  dd2d31b560011ea673e197251e710e52669d911367d83cd3cfd018f8ed58bde9  LICENSE

+ 23 - 0
package/ibm-sw-tpm2/ibm-sw-tpm2.mk

@@ -0,0 +1,23 @@
+################################################################################
+#
+# ibm-sw-tpm2
+#
+################################################################################
+
+IBM_SW_TPM2_VERSION = 1563
+IBM_SW_TPM2_SOURCE = ibmtpm$(IBM_SW_TPM2_VERSION).tar.gz
+IBM_SW_TPM2_SITE = https://sourceforge.net/projects/ibmswtpm2/files
+IBM_SW_TPM2_LICENSE = BSD-3-Clause
+IBM_SW_TPM2_LICENSE_FILES = LICENSE
+IBM_SW_TPM2_DEPENDENCIES = openssl
+
+define IBM_SW_TPM2_BUILD_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS)
+endef
+
+define IBM_SW_TPM2_INSTALL_TARGET_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS) install \
+		DESTDIR=$(TARGET_DIR)
+endef
+
+$(eval $(generic-package))