Procházet zdrojové kódy

package/daq: fix parallel build

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Bernd Kuhls před 3 roky
rodič
revize
41ff126ac1
2 změnil soubory, kde provedl 31 přidání a 4 odebrání
  1. 29 0
      package/daq/0002-parallel-grammar.patch
  2. 2 4
      package/daq/daq.mk

+ 29 - 0
package/daq/0002-parallel-grammar.patch

@@ -0,0 +1,29 @@
+Fix parallel build
+
+https://bugs.gentoo.org/673390
+
+Downloaded from
+https://gitweb.gentoo.org/repo/gentoo.git/tree/net-libs/daq/files/daq-2.0.6-parallel-grammar.patch
+
+Patch was sent upstream: https://seclists.org/snort/2014/q3/1016
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- a/sfbpf/Makefile.am
++++ b/sfbpf/Makefile.am
+@@ -43,13 +43,14 @@
+ libsfbpf_la_LDFLAGS = -version-info 0:1:0 @XCCFLAGS@
+ 
+ # use of $@ and $< here is a GNU idiom that borks BSD
+-sf_scanner.c: $(srcdir)/scanner.l
++sf_scanner.c: $(srcdir)/scanner.l tokdefs.h
+ 	@rm -f $(srcdir)/sf_scanner.c
+ 	$(srcdir)/runlex.sh $(V_LEX) -osf_scanner.c $(srcdir)/scanner.l
+ 
+ sf_scanner.o: sf_scanner.c tokdefs.h
+ 
+ tokdefs.h: sf_grammar.c
++
+ sf_grammar.c: $(srcdir)/grammar.y
+ 	@rm -f sf_grammar.c tokdefs.h
+ 	$(V_YACC) -d $(srcdir)/grammar.y

+ 2 - 4
package/daq/daq.mk

@@ -10,10 +10,8 @@ DAQ_LICENSE = GPL-2.0
 DAQ_LICENSE_FILES = COPYING
 DAQ_INSTALL_STAGING = YES
 DAQ_DEPENDENCIES = host-bison host-flex
-
-# package does not build in parallel due to improper make rules
-# related to the generation of the tokdefs.h header file
-DAQ_MAKE = $(MAKE1)
+# 0002-parallel-grammar.patch
+DAQ_AUTORECONF = YES
 
 # disable ipq module as libipq is deprecated
 DAQ_CONF_OPTS += --disable-ipq-module