Browse Source

package/lynx: fix reproducible build issues

Fixes (part of) http://autobuild.buildroot.net/results/23fe4365ca65f37eace8265a70fbfb9723b8ee9d/

Lynx by default contains logic to generate a "configuration info" HTML page,
which leaks build paths, and adds the build timestamp to the version output.
Disable both when building in reproducible mode.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Peter Korsgaard 3 years ago
parent
commit
3fb7c63687
1 changed files with 8 additions and 1 deletions
  1. 8 1
      package/lynx/lynx.mk

+ 8 - 1
package/lynx/lynx.mk

@@ -12,6 +12,13 @@ LYNX_LICENSE_FILES = COPYING
 
 LYNX_DEPENDENCIES = host-pkgconf $(TARGET_NLS_DEPENDENCIES)
 
+ifeq ($(BR2_REPRODUCIBLE),y)
+# configuration info leaks build paths
+LYNX_CONF_OPTS += --disable-config-info
+# disable build timestamp
+LYNX_CFLAGS += -DNO_BUILDSTAMP
+endif
+
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 LYNX_DEPENDENCIES += ncurses
 LYNX_CONF_OPTS += --with-screen=ncurses$(if $(BR2_PACKAGE_NCURSES_WCHAR),w)
@@ -41,6 +48,6 @@ LYNX_DEPENDENCIES += libidn
 LYNX_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libidn`
 endif
 
-LYNX_CONF_ENV = LIBS="$(LYNX_LIBS)"
+LYNX_CONF_ENV = LIBS="$(LYNX_LIBS)" CFLAGS="$(TARGET_CFLAGS) $(LYNX_CFLAGS)"
 
 $(eval $(autotools-package))