Browse Source

lcdproc: fix autobuild errors

The autobuilders are falling over building lcdproc, with failures like the
following.

  http://autobuild.buildroot.net/results/622b7da10be751c725ba25eb40102269790b4b03/build-end.log

As Thomas Petazzoni has pointed out, the compile command lines incorrectly
contain host header and library search paths, such as the following.

  -I/home/peko/scratch/host/usr/include/freetype2
  -L/home/peko/scratch/host/usr/lib -lfreetype

This patch changes the lcdproc package to pass the freetype installation
prefixes on the configure command line.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Simon Dawson 11 years ago
parent
commit
3bdbe9abb9
1 changed files with 3 additions and 1 deletions
  1. 3 1
      package/lcdproc/lcdproc.mk

+ 3 - 1
package/lcdproc/lcdproc.mk

@@ -10,7 +10,9 @@ LCDPROC_LICENSE = GPLv2+
 LCDPROC_LICENSE_FILES = COPYING
 LCDPROC_MAKE = $(MAKE1)
 
-LCDPROC_CONF_OPT = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS)
+LCDPROC_CONF_OPT = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS) \
+	--with-ft-prefix="$(STAGING_DIR)/usr" \
+	--with-ft-exec-prefix="$(STAGING_DIR)/usr"
 
 ifeq ($(BR2_PACKAGE_LCDPROC_MENUS),y)
 LCDPROC_CONF_OPT += --enable-lcdproc-menus