Browse Source

package/libselinux: enable kernel selinux support for ubifs images

If BR2_TARGET_ROOTFS_UBIFS is selected, enable the following kernel options:
  - CONFIG_UBIFS_FS_XATTR
  - CONFIG_UBIFS_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Adam Duskett 3 years ago
parent
commit
3ab421080c
1 changed files with 3 additions and 0 deletions
  1. 3 0
      package/libselinux/libselinux.mk

+ 3 - 0
package/libselinux/libselinux.mk

@@ -129,6 +129,9 @@ define LIBSELINUX_LINUX_CONFIG_FIXUPS
 		$(call KCONFIG_ENABLE_OPT,CONFIG_JFS_SECURITY))
 	$(if $(BR2_TARGET_ROOTFS_SQUASHFS),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_SQUASHFS_XATTR))
+	$(if $(BR2_TARGET_ROOTFS_UBIFS),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_UBIFS_FS_XATTR)
+		$(call KCONFIG_ENABLE_OPT,CONFIG_UBIFS_FS_SECURITY))
 endef
 
 $(eval $(generic-package))