Browse Source

package/bayer2rgb-neon: new package

bayer2rgb-neon[1] is a library which allows decoding raw camera bayer
to RGB using NEON hardware acceleration.

[1]: https://git.phytec.de/bayer2rgb-neon/

Signed-off-by: Eloi Bail <eloi.bail@savoirfairelinux.com>
[Thomas:
 - use "config" instead of "menuconfig"
 - use BR2_ARM_CPU_HAS_NEON instead of BR2_ARM_ENABLE_NEON
 - use BR2_INSTALL_LIBSTDCPP instead of BR2_TOOLCHAIN_BUILDROOT_CXX
 - add dependency on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9, because the code
   is using C++11
 - add missing Config.in comment
 - drop --prefix=/usr from CONF_OPTS, it is passed by the
   autotools-package infrastructure
 - simplify CFLAGS logic
 - move from "Applications" to "Libraries" in menuconfig
 - add missing .hash file
 - add entry in DEVELOPERS file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Eloi Bail 5 years ago
parent
commit
28f68ce5d8

+ 3 - 0
DEVELOPERS

@@ -648,6 +648,9 @@ F:	package/prosody/
 N:	Ed Swierk <eswierk@skyportsystems.com>
 F:	package/xxhash/
 
+N:	Eloi Bail <eloi.bail@savoirfairelinux.com>
+F:	package/bayer2rgb-neon/
+
 N:	Eric Le Bihan <eric.le.bihan.dev@free.fr>
 F:	docs/manual/adding-packages-meson.txt
 F:	package/adwaita-icon-theme/

+ 1 - 0
package/Config.in

@@ -1250,6 +1250,7 @@ menu "Graphics"
 	source "package/at-spi2-core/Config.in"
 	source "package/atk/Config.in"
 	source "package/atkmm/Config.in"
+	source "package/bayer2rgb-neon/Config.in"
 	source "package/bullet/Config.in"
 	source "package/cairo/Config.in"
 	source "package/cairomm/Config.in"

+ 17 - 0
package/bayer2rgb-neon/Config.in

@@ -0,0 +1,17 @@
+config BR2_PACKAGE_BAYER2RGB_NEON
+	bool "bayer2rgb-neon"
+	depends on BR2_arm && BR2_ARM_CPU_HAS_NEON
+	depends on !BR2_STATIC_LIBS
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++11
+	help
+	  bayer2rgb-neon is a library which allows
+	  to decode raw camera bayer to RGB using
+	  NEON hardware acceleration.
+
+	  https://git.phytec.de/bayer2rgb-neon/
+
+comment "bayer2rgb-neon needs a toolchain w/ C++, dynamic library, gcc >= 4.9"
+	depends on BR2_arm && BR2_ARM_CPU_HAS_NEON
+	depends on BR2_STATIC_LIBS || !BR2_INSTALL_LIBSTDCPP || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9

+ 3 - 0
package/bayer2rgb-neon/bayer2rgb-neon.hash

@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 b14c8b2b86207fe8222f79bef83dc3ae94222827f1882466ca65705238d15085 bayer2rgb-neon-v0.4.tar.bz2
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING

+ 24 - 0
package/bayer2rgb-neon/bayer2rgb-neon.mk

@@ -0,0 +1,24 @@
+################################################################################
+#
+# bayer2rgb-neon
+#
+################################################################################
+
+BAYER2RGB_NEON_VERSION = v0.4
+BAYER2RGB_NEON_SOURCE = bayer2rgb-neon-$(BAYER2RGB_NEON_VERSION).tar.bz2
+BAYER2RGB_NEON_SITE = https://git.phytec.de/bayer2rgb-neon/snapshot
+BAYER2RGB_NEON_LICENSE = GPL-3.0
+BAYER2RGB_NEON_LICENSE_FILES = COPYING
+BAYER2RGB_NEON_INSTALL_STAGING = YES
+BAYER2RGB_NEON_DEPENDENCIES = host-pkgconf host-gengetopt
+BAYER2RGB_NEON_AUTORECONF = YES
+
+BAYER2RGB_NEON_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -mfpu=neon"
+
+define BAYER2RGB_NEON_PRE_CONFIGURE_FIXUP
+	mkdir -p $(@D)/m4
+endef
+
+BAYER2RGB_NEON_PRE_CONFIGURE_HOOKS += BAYER2RGB_NEON_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))