Bladeren bron

package/environment-setup: add configure alias

In order to simplify the usage of a buildroot toolchain within
the buildroot shell, a "configure" alias is provided to call
./configure with the correct flags.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Angelo Compagnucci 4 jaren geleden
bovenliggende
commit
26cb4e72e1

+ 4 - 3
docs/manual/using-buildroot-toolchain.txt

@@ -42,6 +42,7 @@ variables that will help cross-compile your projects using the
 Buildroot SDK: the +PATH+ will contain the SDK binaries, standard
 _autotools_ variables will be defined with the appropriate values, and
 +CONFIGURE_FLAGS+ will contain basic +./configure+ options to
-cross-compile _autotools_ projects. Note however that once this script
-is sourced, the environment is setup only for cross-compilation, and
-no longer for native compilation.
+cross-compile _autotools_ projects. It also provides some useful
+commands. Note however that once this script is sourced, the
+environment is setup only for cross-compilation, and no longer for
+native compilation.

+ 2 - 1
package/environment-setup/environment-setup

@@ -10,7 +10,8 @@ cat <<'EOF'
 Some tips:
 * PATH now contains the SDK utilities
 * Standard autotools variables (CC, LD, CFLAGS) are exported
-* To configure do "./configure $CONFIGURE_FLAGS"
+* To configure do "./configure $CONFIGURE_FLAGS" or use
+  the "configure" alias
 
 EOF
 SDK_PATH=$(dirname $(realpath "${BASH_SOURCE[0]}"))

+ 2 - 0
package/environment-setup/environment-setup.mk

@@ -20,6 +20,8 @@ define HOST_ENVIRONMENT_SETUP_INSTALL_CMDS
 		--sysconfdir=/etc \
 		--localstatedir=/var \
 		--program-prefix=\"\n" >> $(ENVIRONMENT_SETUP_FILE)
+	printf "alias configure=\"./configure \$${CONFIGURE_FLAGS}\"\n" \
+		>> $(ENVIRONMENT_SETUP_FILE)
 	$(SED) 's%$(HOST_DIR)%\$$SDK_PATH%g' \
 		-e 's%$(HOST_DIR)/bin/%%g' \
 		-e '/^export "PATH=/c\' \