소스 검색

Revert "package/Makefile.in should grab HOST_DIR headers using -isystem instead of -I."

This reverts commit 6f8162cf8c1abef7e0a4771fe0d6b26a28f5c2b6. This is
causing too many problems that are not easy to solve.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni 7 년 전
부모
커밋
255b6f80d3
1개의 변경된 파일1개의 추가작업 그리고 1개의 파일을 삭제
  1. 1 1
      package/Makefile.in

+ 1 - 1
package/Makefile.in

@@ -222,7 +222,7 @@ UNZIP := $(shell which unzip || type -p unzip) -q
 
 APPLY_PATCHES = support/scripts/apply-patches.sh $(if $(QUIET),-s)
 
-HOST_CPPFLAGS  = -isystem $(HOST_DIR)/usr/include
+HOST_CPPFLAGS  = -I$(HOST_DIR)/usr/include
 HOST_CFLAGS   ?= -O2
 HOST_CFLAGS   += $(HOST_CPPFLAGS)
 HOST_CXXFLAGS += $(HOST_CFLAGS)