Browse Source

toolchain/toolchain: set TOOLCHAIN_INSTALL_STAGING only once

Currently, we set TOOLCHAIN_INSTALL_STAGING three times: once
(conditionally) in toolchain.mk, and once each (unconditionally) in
pkg-cmake.mk and pkg-meson.mk.

This is a little bit messy... Set it just once, unconditionally, in
toolchain.mk where it belongs.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Arnout Vandecappelle (Essensium/Mind) 4 years ago
parent
commit
212adf32f3
3 changed files with 1 additions and 3 deletions
  1. 0 1
      package/pkg-cmake.mk
  2. 0 1
      package/pkg-meson.mk
  3. 1 1
      toolchain/toolchain/toolchain.mk

+ 0 - 1
package/pkg-cmake.mk

@@ -272,4 +272,3 @@ define TOOLCHAIN_CMAKE_INSTALL_FILES
 endef
 
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_CMAKE_INSTALL_FILES
-TOOLCHAIN_INSTALL_STAGING = YES

+ 0 - 1
package/pkg-meson.mk

@@ -206,4 +206,3 @@ define PKG_MESON_INSTALL_CROSS_CONF
 endef
 
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += HOST_MESON_INSTALL_CROSS_CONF
-TOOLCHAIN_INSTALL_STAGING = YES

+ 1 - 1
toolchain/toolchain/toolchain.mk

@@ -11,6 +11,7 @@ TOOLCHAIN_DEPENDENCIES += toolchain-external
 endif
 
 TOOLCHAIN_ADD_TOOLCHAIN_DEPENDENCY = NO
+TOOLCHAIN_INSTALL_STAGING = YES
 
 # Apply a hack that Rick Felker suggested[1] to avoid conflicts between libc
 # headers and kernel headers. This is needed for kernel headers older than
@@ -34,7 +35,6 @@ define TOOLCHAIN_MUSL_KERNEL_HEADERS_COMPATIBILITY_HACK
 		$(STAGING_DIR)/usr/include/linux/libc-compat.h
 endef
 TOOLCHAIN_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_MUSL_KERNEL_HEADERS_COMPATIBILITY_HACK
-TOOLCHAIN_INSTALL_STAGING = YES
 endif
 
 # Install default nsswitch.conf file if the skeleton doesn't provide it