Selaa lähdekoodia

package/simicsfs: remove package

Buildroot currently packages version 1.18 of simics, which is quite
out of date, and does not compile with Linux 4.12+. The latest package
v1.22 supports recent kernels, however that is not publicly available
anymore like the older versions.

In fact Simics is now moving away from the simicsfs kernel module, as
the kernel module has required too much maintenance work. Users should
move to the new user mode Simics agent instead. Therefore, we drop the
corresponding package from Buildroot.

Signed-off-by: Bin Meng <bmeng.cn@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Bin Meng 6 vuotta sitten
vanhempi
commit
20db09895d
6 muutettua tiedostoa jossa 13 lisäystä ja 28 poistoa
  1. 13 0
      Config.in.legacy
  2. 0 1
      DEVELOPERS
  3. 0 1
      package/Config.in
  4. 0 11
      package/simicsfs/Config.in
  5. 0 2
      package/simicsfs/simicsfs.hash
  6. 0 13
      package/simicsfs/simicsfs.mk

+ 13 - 0
Config.in.legacy

@@ -145,6 +145,19 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.08"
 
+config BR2_PACKAGE_SIMICSFS
+	bool "simicsfs support removed"
+	select BR2_LEGACY
+	help
+	  Support for simicsfs kernel driver that provides access to a
+	  host computer's local filesystem when the target is
+	  executing within a SIMICS simulation has been removed.
+
+	  Simics is now moving away from the simicsfs kernel module,
+	  as the kernel module has required too much maintenance
+	  work. Users should move to the user mode Simics agent
+	  instead.
+
 config BR2_BINUTILS_VERSION_2_26_X
 	bool "binutils version 2.26 support removed"
 	select BR2_LEGACY

+ 0 - 1
DEVELOPERS

@@ -1162,7 +1162,6 @@ F:	package/python-pyrex/
 F:	package/raptor/
 F:	package/sepolgen/
 F:	package/setools/
-F:	package/simicsfs/
 F:	package/smcroute/
 F:	package/tclap/
 F:	package/valijson/

+ 0 - 1
package/Config.in

@@ -189,7 +189,6 @@ menu "Filesystem and flash utilities"
 	source "package/mtools/Config.in"
 	source "package/nfs-utils/Config.in"
 	source "package/ntfs-3g/Config.in"
-	source "package/simicsfs/Config.in"
 	source "package/sp-oops-extract/Config.in"
 	source "package/squashfs/Config.in"
 	source "package/sshfs/Config.in"

+ 0 - 11
package/simicsfs/Config.in

@@ -1,11 +0,0 @@
-comment "simicsfs needs a Linux kernel to be built"
-	depends on !BR2_LINUX_KERNEL
-
-config BR2_PACKAGE_SIMICSFS
-	bool "simicsfs"
-	depends on BR2_LINUX_KERNEL
-	help
-	  A kernel driver that provides access to a host computer's local
-	  filesystem when the target is executing within a SIMICS simulation.
-
-	  http://www.cs.sfu.ca/~fedorova/Tech/simics-guides-3.0.26/simics-user-guide-unix/topic33.html

+ 0 - 2
package/simicsfs/simicsfs.hash

@@ -1,2 +0,0 @@
-# Locally calculated
-sha256	d0cf7caf888dc1e7dc9496c4b59af98eb2b69d6113d6920757465902e1f21f38	simicsfs-1.18.tar.gz

+ 0 - 13
package/simicsfs/simicsfs.mk

@@ -1,13 +0,0 @@
-################################################################################
-#
-# simicsfs
-#
-################################################################################
-
-SIMICSFS_VERSION = 1.18
-SIMICSFS_SITE = http://download.simics.net/pub
-SIMICSFS_LICENSE = GPL-2.0+
-SIMICSFS_LICENSE_FILES = hostfs.h
-
-$(eval $(kernel-module))
-$(eval $(generic-package))