Browse Source

package/time: New package for GNU time.

Signed-off-by: Will Newton <will.newton@imgtec.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Will Newton 11 years ago
parent
commit
2073c21ec0
3 changed files with 24 additions and 0 deletions
  1. 1 0
      package/Config.in
  2. 6 0
      package/time/Config.in
  3. 17 0
      package/time/time.mk

+ 1 - 0
package/Config.in

@@ -672,6 +672,7 @@ source "package/logsurfer/Config.in"
 source "package/screen/Config.in"
 source "package/sudo/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
+source "package/time/Config.in"
 source "package/which/Config.in"
 endif
 source "package/xmlstarlet/Config.in"

+ 6 - 0
package/time/Config.in

@@ -0,0 +1,6 @@
+config BR2_PACKAGE_TIME
+	bool "time"
+	help
+	  The GNU time utility.
+
+	  http://savannah.gnu.org/projects/time/

+ 17 - 0
package/time/time.mk

@@ -0,0 +1,17 @@
+#############################################################
+#
+# time
+#
+#############################################################
+
+TIME_VERSION = 1.7
+TIME_SITE = $(BR2_GNU_MIRROR)/time
+TIME_CONF_ENV = ac_cv_func_wait3=yes
+
+# time uses an old version of automake that does not support
+# installing in DESTDIR.
+define TIME_INSTALL_TARGET_CMDS
+	install -D -m 755  $(@D)/time $(TARGET_DIR)/usr/bin/time
+endef
+
+$(eval $(autotools-package))