Browse Source

iproute2: fix em_ipset build issue

Fixes http://autobuild.buildroot.net/results/be19e39c19b62946ea48dd6b3dfd55f5c3ccd7c9

em_ipset.c uses xtables.h from iptables, but the configure script fails
to to check for this, so forcibly disable it if not available.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Peter Korsgaard 11 years ago
parent
commit
1b5ce0e9a2
1 changed files with 5 additions and 0 deletions
  1. 5 0
      package/iproute2/iproute2.mk

+ 5 - 0
package/iproute2/iproute2.mk

@@ -24,6 +24,11 @@ define IPROUTE2_WITH_IPTABLES
 	$(SED) "s/-DIPT/-DXT/" $(IPROUTE2_DIR)/tc/Makefile
 	echo "TC_CONFIG_XT:=y" >>$(IPROUTE2_DIR)/Config
 endef
+else
+define IPROUTE2_WITH_IPTABLES
+	# em_ipset needs xtables, but configure misdetects it
+	echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
+endef
 endif
 
 define IPROUTE2_CONFIGURE_CMDS