Browse Source

support/dependencies: clarify intended use of host bison/flex

We should not rely on host installed bison/flex for target code. This
ensures better reproducibility of generated code.

http://lists.busybox.net/pipermail/buildroot/2020-November/296786.html

Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Baruch Siach 3 years ago
parent
commit
1b1c049af2
1 changed files with 4 additions and 0 deletions
  1. 4 0
      support/dependencies/check-host-bison-flex.mk

+ 4 - 0
support/dependencies/check-host-bison-flex.mk

@@ -1,5 +1,9 @@
 # If the system lacks bison or flex, add
 # dependencies to suitable host packages
+#
+# BR2_{BISON,FLES}_HOST_DEPENDENCY should only be used to build code
+# that runs on host, e.g. Kconfig. To build code for target use plain
+# host-{bison,flex}.
 
 ifeq ($(shell which bison 2>/dev/null),)
 BR2_BISON_HOST_DEPENDENCY = host-bison