Browse Source

package/ffmpeg: enable libv4l2 when selected

Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Joseph Kogut 3 years ago
parent
commit
11a9810a54
1 changed files with 7 additions and 0 deletions
  1. 7 0
      package/ffmpeg/ffmpeg.mk

+ 7 - 0
package/ffmpeg/ffmpeg.mk

@@ -84,6 +84,13 @@ else
 FFMPEG_CONF_OPTS += --disable-ffplay
 endif
 
+ifeq ($(BR2_PACKAGE_LIBV4L),y)
+FFMPEG_DEPENDENCIES += libv4l
+FFMPEG_CONF_OPTS += --enable-libv4l2
+else
+FFMPEG_CONF_OPTS += --disable-libv4l2
+endif
+
 ifeq ($(BR2_PACKAGE_FFMPEG_AVRESAMPLE),y)
 FFMPEG_CONF_OPTS += --enable-avresample
 else