瀏覽代碼

ffmpeg: Add sse4 related options BR2_X86_CPU_HAS_SSE4 / BR2_X86_CPU_HAS_SSE4

Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Bernd Kuhls 10 年之前
父節點
當前提交
0e8e3c2879
共有 2 個文件被更改,包括 16 次插入0 次删除
  1. 4 0
      arch/Config.in.x86
  2. 12 0
      package/ffmpeg/ffmpeg.mk

+ 4 - 0
arch/Config.in.x86

@@ -9,6 +9,10 @@ config BR2_X86_CPU_HAS_SSE3
 	bool
 config BR2_X86_CPU_HAS_SSSE3
 	bool
+config BR2_X86_CPU_HAS_SSE4
+	bool
+config BR2_X86_CPU_HAS_SSE42
+	bool
 
 choice
 	prompt "Target Architecture Variant"

+ 12 - 0
package/ffmpeg/ffmpeg.mk

@@ -249,6 +249,18 @@ else
 FFMPEG_CONF_OPT += --disable-ssse3
 endif
 
+ifeq ($(BR2_X86_CPU_HAS_SSE4),y)
+FFMPEG_CONF_OPT += --enable-sse4
+else
+FFMPEG_CONF_OPT += --disable-sse4
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE42),y)
+FFMPEG_CONF_OPT += --enable-sse42
+else
+FFMPEG_CONF_OPT += --disable-sse42
+endif
+
 # Explicitly disable everything that doesn't match for ARM
 # FFMPEG "autodetects" by compiling an extended instruction via AS
 # This works on compilers that aren't built for generic by default