Parcourir la source

fs/common.mk: do not store original names and timestamps when creating gzipped rootfs

Using the GZIP environment variable to pass gzip options is
deprecated, and therefore we are going to remove the "GZIP = -n"
definition from the main Buildroot Makefile. In preparation for this,
we explicitly add the -n argument to the gzip call in fs/common.mk to
ensure reproducibility.

Signed-off-by: Atharva Lele <itsatharva@gmail.com>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit 44d17dd128164cfe7870f5bef279e273ba59f83d)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Atharva Lele il y a 4 ans
Parent
commit
098cea58fc
1 fichiers modifiés avec 1 ajouts et 1 suppressions
  1. 1 1
      fs/common.mk

+ 1 - 1
fs/common.mk

@@ -82,7 +82,7 @@ ROOTFS_$(2)_DEPENDENCIES += rootfs-common
 
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_GZIP),y)
 ROOTFS_$(2)_COMPRESS_EXT = .gz
-ROOTFS_$(2)_COMPRESS_CMD = gzip -9 -c
+ROOTFS_$(2)_COMPRESS_CMD = gzip -9 -c -n
 endif
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_BZIP2),y)
 ROOTFS_$(2)_COMPRESS_EXT = .bz2