Browse Source

package/iwd: bump version to 1.10

- remove 0001-src-ap.c-fix-build-with-uclibc.patch
  (upstream committed, see [1])

- drop dynamic library dependency as no longer enforced by ell
  and no longer needed since commit [2]

Changelog (since 1.9):
  - Add support for DHCP v6 configuration.
  - Add support for DHCP server operation with AP mode.
  - Add support for IP allocation during the 4-Way Handshake.
  - Add support for P2P Group-owner handling.

[1] https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=0a6de7932a61ec82aca4f78f71dab7247c897860
[2] https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=bbcfde8743c4dd58379d2017b7f0fabe8d65fffa

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Peter Seiderer 3 years ago
parent
commit
04fa606640

+ 0 - 36
package/iwd/0001-src-ap.c-fix-build-with-uclibc.patch

@@ -1,36 +0,0 @@
-From 377df79e83e2127a087e1aa5ba6173e195e50933 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Thu, 10 Sep 2020 07:47:14 +0200
-Subject: [PATCH] src/ap.c: fix build with uclibc
-
-explicit_bzero is used in src/ap.c since commit
-d55e00b31d7bccdbb2ea1cdeb0a749df77a51e47 but src/missing.h is not
-included, as a result build with uclibc fails on:
-
-/srv/storage/autobuild/run/instance-1/output-1/host/lib/gcc/xtensa-buildroot-linux-uclibc/9.3.0/../../../../xtensa-buildroot-linux-uclibc/bin/ld: src/ap.o: in function `ap_probe_req_cb':
-ap.c:(.text+0x23d8): undefined reference to `explicit_bzero'
-
-Fixes:
- - http://autobuild.buildroot.org/results/c7a0096a269bfc52bd8e23d453d36d5bfb61441d
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream: https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=0a6de7932a61ec82aca4f78f71dab7247c897860]
----
- src/ap.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/ap.c b/src/ap.c
-index c972cfcb..ac705c31 100644
---- a/src/ap.c
-+++ b/src/ap.c
-@@ -31,6 +31,7 @@
- 
- #include "linux/nl80211.h"
- 
-+#include "src/missing.h"
- #include "src/iwd.h"
- #include "src/module.h"
- #include "src/scan.h"
--- 
-2.28.0
-

+ 3 - 4
package/iwd/Config.in

@@ -4,7 +4,6 @@ config BR2_PACKAGE_IWD
 	depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # ell
 	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12 # ell
-	depends on !BR2_STATIC_LIBS # ell
 	depends on BR2_USE_WCHAR # ell
 	select BR2_PACKAGE_DBUS # runtime
 	select BR2_PACKAGE_ELL
@@ -14,8 +13,8 @@ config BR2_PACKAGE_IWD
 
 	  https://iwd.wiki.kernel.org/
 
-comment "iwd needs a toolchain w/ threads, dynamic library, wchar, headers >= 4.12"
+comment "iwd needs a toolchain w/ threads, wchar, headers >= 4.12"
 	depends on BR2_USE_MMU # dbus
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # ell
-	depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS || \
-		!BR2_USE_WCHAR || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12
+	depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR || \
+		!BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12

+ 1 - 1
package/iwd/iwd.hash

@@ -1,5 +1,5 @@
 # Locally computed
-sha256  e4178a105021ef1b7b7c23cbc6f8e45cbab3bb0830da588b406ff4a281e9f948  iwd-1.9.tar.gz
+sha256  4f0007fb7594fe59baed71fb72c8390c472ff11c38b75d1f673375d4129ba5e2  iwd-1.10.tar.gz
 
 # License files
 sha256  ec60b993835e2c6b79e6d9226345f4e614e686eb57dc13b6420c15a33a8996e5  COPYING

+ 1 - 1
package/iwd/iwd.mk

@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IWD_VERSION = 1.9
+IWD_VERSION = 1.10
 IWD_SITE = https://git.kernel.org/pub/scm/network/wireless/iwd.git
 IWD_SITE_METHOD = git
 IWD_LICENSE = LGPL-2.1+