Browse Source

jh8100: nodejs: Fix build with gcc-13

Added patch to fix build with gcc-13 due to header dependency changes.
Reference: https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 3 months ago
parent
commit
535e540ec6

+ 24 - 0
recipes-devtools/nodejs/nodejs/0001-fix-build-with-gcc-13.patch

@@ -0,0 +1,24 @@
+diff --git a/deps/v8/src/base/logging.h b/deps/v8/src/base/logging.h
+index 08db24a..38be165 100644
+--- a/deps/v8/src/base/logging.h
++++ b/deps/v8/src/base/logging.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_BASE_LOGGING_H_
+ #define V8_BASE_LOGGING_H_
+ 
++#include <cstdint>
+ #include <cstring>
+ #include <sstream>
+ #include <string>
+diff --git a/deps/v8/src/inspector/v8-string-conversions.h b/deps/v8/src/inspector/v8-string-conversions.h
+index c1d69c1..eb33c68 100644
+--- a/deps/v8/src/inspector/v8-string-conversions.h
++++ b/deps/v8/src/inspector/v8-string-conversions.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
+ #define V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
+ 
++#include <cstdint>
+ #include <string>
+ 
+ // Conversion routines between UT8 and UTF16, used by string-16.{h,cc}. You may

+ 1 - 0
recipes-devtools/nodejs/nodejs_18.0.0.bb

@@ -21,6 +21,7 @@ COMPATIBLE_HOST:powerpc = "null"
 
 SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
            file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
+	   file://0001-fix-build-with-gcc-13.patch \
            file://0004-v8-don-t-override-ARM-CFLAGS.patch \
            file://system-c-ares.patch \
            file://run-ptest \