Browse Source

jh8100: mnn: Fix build with gcc-13

Added patch to fix build with gcc-13 due to header dependency changes.
Reference: https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 3 months ago
parent
commit
5b0089ba89

+ 12 - 0
recipes-extended/mnn/mnn/0001-fix-build-with-gcc-13.patch

@@ -0,0 +1,12 @@
+diff --git a/test/MNNTestSuite.h b/test/MNNTestSuite.h
+index a7ea46e4..52ade143 100644
+--- a/test/MNNTestSuite.h
++++ b/test/MNNTestSuite.h
+@@ -27,6 +27,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <dirent.h>
++#include <cstdint>
+ #endif
+ 
+ static inline uint64_t getTimeInUs() {

+ 4 - 2
recipes-extended/mnn/mnn_2.6.0.bb

@@ -1,13 +1,15 @@
 DESCRIPTION = "MNN is a blazing fast, lightweight deep learning framework, battle-tested by business-critical use cases in Alibaba"
 HOMEPAGE = "www.mnn.zone"
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README.md;startline=124;endline=125;md5=49af4a1302656dc01a1c983ee77b8227"
+LIC_FILES_CHKSUM = "file://README.md;startline=124;endline=125;md5=866c85dec0fa0932d17067810bf0e08c"
 
 SRC_URI = " \
     git://github.com/alibaba/MNN.git;branch=master;protocol=https \
     file://run-ptest \
+    file://0001-fix-build-with-gcc-13.patch \
 "
-SRCREV = "c293f9eeab0a2983aa260ca81c751b09a389b16d"
+SRCREV = "d20f37fd7134127dde9201e74d38dc0c08d4a096"
+
 S = "${WORKDIR}/git"
 
 inherit cmake ptest