hello.bb 566 B

123456789101112131415161718192021222324252627
  1. DESCRIPTION = "Hello World and Zlib test"
  2. DEPENDS = "zlib"
  3. SECTION = "libs"
  4. LICENSE = "MIT"
  5. PV = "3"
  6. PR = "r0"
  7. SRC_URI = " \
  8. file://helloYocto.c \
  9. file://zlibtest.c \
  10. file://makefile \
  11. "
  12. LIC_FILES_CHKSUM = "file://helloYocto.c;md5=2dac018fa193620dc085aa1402e0b346"
  13. S = "${WORKDIR}"
  14. do_compile () {
  15. make
  16. }
  17. do_install () {
  18. install -d ${D}${bindir}/
  19. install -m 0755 ${S}/helloYocto ${D}${bindir}/
  20. install -m 0755 ${S}/zlibtest ${D}${bindir}/
  21. }
  22. FILES:${PN} = "${bindir}/helloYocto \
  23. ${bindir}/zlibtest "