xfce.bbclass 473 B

1234567891011121314
  1. def xfce_verdir(v):
  2. import re
  3. m = re.match(r"^([0-9]+)\.([0-9]+)", v)
  4. return "%s.%s" % (m.group(1), m.group(2))
  5. HOMEPAGE = "http://www.xfce.org"
  6. SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@xfce_verdir("${PV}")}/${BPN}-${PV}.tar.bz2"
  7. inherit autotools gettext gtk-icon-cache pkgconfig
  8. DEPENDS += "intltool-native"
  9. FILES:${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
  10. FILES:${PN}-doc += "${datadir}/xfce4/doc"