kernel_wireless_regdb.bbclass 705 B

1234567891011121314151617181920
  1. # Linux kernels before v4.15, allowed to be compiled with static
  2. # regulatory database if it was put under net/wireless/db.txt.
  3. #
  4. # This class copies the regulatory plaintext database to kernel sources before
  5. # compiling.
  6. #
  7. # Usage:
  8. # 1. The class should be inherited by kernel recipe (e.g. in
  9. # linux-yocto_%.bbappend).
  10. # 2. For Linux kernels up to v4.14, build kernel with CONFIG_EXPERT and
  11. # CONFIG_CFG80211_INTERNAL_REGDB.
  12. DEPENDS += "wireless-regdb-native"
  13. SRCTREECOVEREDTASKS += "do_kernel_add_regdb"
  14. do_kernel_add_regdb() {
  15. cp ${STAGING_LIBDIR_NATIVE}/crda/db.txt ${S}/net/wireless/db.txt
  16. }
  17. do_kernel_add_regdb[dirs] = "${S}"
  18. addtask kernel_add_regdb before do_build after do_configure